OSC Support International Phone Numbers Not Working

Incident Report for Corrigo

Resolved

All support phone numbers are now functioning as expected. This incident has been resolved.
Posted Mar 06, 2026 - 15:03 CST

Identified

The issue has been identified and restoration efforts are in progress. Estimated to be restored tomorrow, March 6th.
Posted Mar 05, 2026 - 17:22 CST

Update

OneServiceCenter's third party phone provider is actively investigating this issue. We will provide updates as we have them.
Posted Mar 05, 2026 - 07:26 CST

Investigating

JLLT OneServiceCenter is aware of an issue with the following international phone numbers not working. Users may experience automatic hang ups or messages that the number is not in service. We are opening a case with our phone provider to remediate this as soon as possible.

Europe: 08-082349192
Australia: 1-800-875264
Hong Kong: 1-800-961847
Singapore: 1-800-1206973

International users may use other points of contact such as Live Chat (support.jllt.com) or email (support.jllt@jll.com). Support Agents may dial to international numbers if a phone call is needed.
Posted Mar 04, 2026 - 09:04 CST
This incident affected: OneServiceCenter Support Self-Help & MyPortal Sites.