JLLT OneServiceCenter has been alerted to potential service issues with Corrigo Enterprise Back Office Password Resets in v9.23

Incident Report for Corrigo

Resolved

This incident has been resolved.
Posted Sep 03, 2026 - 15:58 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2026 - 14:12 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 03, 2026 - 13:55 CDT

Investigating

JLLT OneServiceCenter has been made aware of an issue that may be affecting services with Corrigo Enterprise version 9.23 where Users are experiencing difficulty resetting their passwords.

Users May Experience: When clicking the password reset link in the Reset Password email, you may be redirected to the generic login screen instead of the standard password reset page.

Temporary Workaround: You may use alternative login methods if they are offered for your company, such as Single-Sign On (SSO), or you may reach out to your company's System Administrator/Technical Contact and have them reset your password manually.

We apologize for the inconvenience and appreciate your patience.

A master case (01042643) has been opened for this issue to track incident volume.
When contacting Support, please reference the master case # if your issue is thought to be related.
Posted Sep 03, 2026 - 12:38 CDT
This incident affected: Americas Region (Corrigo Enterprise 9x), Asia Pacific Region (Corrigo Enterprise), and Europe, the Middle East & Africa Region (Corrigo Enterprise).