A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2025 - 15:50 CST
Investigating
JLLT OneServiceCenter has been made aware of an issue that may be affecting services with Field Service Management (FSM/IFSM), where the Time Card Module and/or Service Agreement module(s) are being turned off/disabled unexpectedly.
If you believe your FSM/IFSM account is affected, please send an email to support.jllt@jll.com, or call OneServiceCenter support at 1-877-701-8326 and follow options for Field Service Management. Please have your account details ready. Our agents will be able to assist you in re-enabling your intended module(s).
A master case (00945931) has been opened for this issue to track incident volume. When contacting Support, please reference the master case # if your issue is thought to be related.
Posted Nov 12, 2025 - 09:07 CST
This incident affected: Americas Region (Field Service Management).