JLLT OneServiceCenter has been alerted to potential service issues with Corrigo Enterprise - Unable to Send Work Orders to Vendors

Incident Report for Corrigo

Resolved

This incident has been resolved.
Posted Dec 19, 2025 - 08:01 CST

Update

We are seeing some intermittent issues of not being able to send work orders or messages across the CorrigoPro network. Our Engineering team is aware and is still working on this and monitoring the situation.
Posted Dec 18, 2025 - 21:03 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 18, 2025 - 19:30 CST

Investigating

JLLT OneServiceCenter has been made aware of an issue that may be affecting services with Corrigo Enterprise when sending work orders to Vendors across the CorrigoPro Network.

Users May Experience: Internal Server Error

Our Product and Engineering teams are actively reviewing this and we will update this status page post when more information or ETA on a fix is provided.

A master case (00967915) has been opened for this issue to track incident volume.
When contacting Support, please reference the master case # if your issue is thought to be related.
Posted Dec 18, 2025 - 18:54 CST
This incident affected: Americas Region (Corrigo Enterprise 9x, CorrigoPro).