We are continuing to monitor for any further issues.
Posted Jan 29, 2026 - 09:32 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 28, 2026 - 15:40 CST
Update
JLLT OneServiceCenter has been informed that other Corrigo products are impacting by this incident. Intuit Field Service Management (FSM), as well as Corrigo Enterprise are both impacted.
Users may experience degraded performance, slowness, unexpected errors messages when navigating or logging in.
Posted Jan 28, 2026 - 13:18 CST
Investigating
JLLT OneServiceCenter has been made aware of an issue that may be affecting services with CorrigoPro being inaccessible in the Americas (AM) Region. This appears to be affecting the Desktop and Mobile versions.
Users May Experience getting "An error occurred while processing your request", slowness/latency in the product, and/or other generic page errors.
A master case (00978942) has been opened for this issue to track incident volume. When contacting Support, please reference the master case # if your issue is thought to be related.
Posted Jan 28, 2026 - 11:08 CST
This incident affected: Americas Region (Corrigo Enterprise 9x, CorrigoPro, Field Service Management), Asia Pacific Region (Corrigo Enterprise, CorrigoPro), and Europe, the Middle East & Africa Region (Corrigo Enterprise, CorrigoPro).