JLLT OneServiceCenter has been alerted to potential service issues with Corrigo Enterprise Back Office (Tech App) Issues

Incident Report for Corrigo

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 09:31 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 28, 2026 - 09:09 CST

Investigating

JLLT OneServiceCenter has been made aware of an issue that may be affecting services with the Corrigo Enterprise Back Office Mobile Application (Tech App). Users may experience the application crashing or becoming unavailable when attempting to add Time/Labor to a Work Order. This is currently only affecting the Americas (AM) Region, and seems to be isolated to iOS.

The current workaround is to attempt to perform these actions in the Back Office Desktop version.

A master case (00978617) has been opened for this issue to track incident volume.
When contacting Support, please reference the master case # if your issue is thought to be related.
Posted Jan 28, 2026 - 08:10 CST
This incident affected: Americas Region (Corrigo Enterprise 9x).