JLLT OneServiceCenter has been alerted to potential service issues with Corrigo Enterprise Customer Portal in the APAC Region

Incident Report for Corrigo

Resolved

This incident has been resolved.
Posted Jun 29, 2026 - 07:49 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 28, 2026 - 18:46 CDT

Investigating

JLLT OneServiceCenter has been made aware of an issue that may be affecting customers with the Corrigo Enterprise Customer Portal availability in the Desktop and Mobile App.

Users May Experience 500 - Internal Server Error

A master case (01023967) has been opened for this issue to track incident volume.
When contacting Support, please reference the master case # if your issue is thought to be related.
Posted Jun 28, 2026 - 18:36 CDT
This incident affected: Asia Pacific Region (Corrigo Enterprise).