JLLT OneServiceCenter has been alerted to potential service issues with Corrigo Enterprise integrations experiencing delayed or failed data synchronization
A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2026 - 09:26 CDT
Identified
JLLT OneServiceCenter has been made aware of an infrastructure issue that is impacting services used by integrations.
Current Status: Our team is actively investigating and working to resolve this issue as quickly as possible. We understand the importance of uninterrupted service to your operations and are prioritizing this matter accordingly.
Impact: Some integrations may experience delayed or failed data synchronization during this period.
Posted Jun 01, 2026 - 09:21 CDT
This incident affected: Asia Pacific Region (Enterprise Integrations), Europe, the Middle East & Africa Region (Enterprise Integrations), and Americas Region (Enterprise Integrations).