Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 25, 2026 - 20:00 CDT
Scheduled
Corrigo Integrators and Administrators:
Production Integrated File System (IFS Integration) Servers will be updated on July 25th 2026 at 8:00 PM CT to 04:00 AM CT
Estimated Duration of Maintenance: 8 hours
During the maintenance window, integrated components may be impacted. (8 Hours)
If you have specific questions about this event, please contact OneServiceCenter at support.jllt@jll.com and a member of the Support Team will contact you with further instructions.
Maintenance completion will be communicated through the status page
Posted Jul 06, 2026 - 12:13 CDT
This scheduled maintenance affected: Asia Pacific Region (Enterprise Integrations - Legacy), Europe, the Middle East & Africa Region (Enterprise Integrations - Legacy), and Americas Region (Enterprise Integrations - Legacy).