Verification is currently underway for the maintenance items.
Posted Aug 20, 2026 - 04:53 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 20, 2026 - 03:30 CDT
Scheduled
Corrigo Integrators and Administrators:
Corrigo Sync Pull handler (IFS Integration) and Push handler will be released on 2026-08-20, 3:30am to 5:30am, 2 hours, CDT]
Estimated Duration of Maintenance: 2 hours
During the maintenance window, integrated components may be impacted.
If you have specific questions about this event, please contact OneServiceCenter at support.jllt@jll.com and a member of the Support Team will contact you with further instructions.
Maintenance completion will be communicated through the status page
Posted Aug 19, 2026 - 10:47 CDT
This scheduled maintenance affected: Asia Pacific Region (Enterprise Integrations - CorrigoSync), Europe, the Middle East & Africa Region (Enterprise Integrations - CorrigoSync), and Americas Region (Enterprise Integrations - CorrigoSync).