A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2026 - 23:24 CST
Investigating
JLLT OneServiceCenter has been made aware of an issue that may be affecting services with CorrigoPro and FSM being inaccessible in the Americas (AM) Region. This appears to be affecting the Desktop and Mobile versions.
Users May Experience getting "An error occurred while processing your request", slowness/latency in the product, and/or other generic page errors.
A master case (00990879) has been opened for this issue to track incident volume. When contacting Support, please reference the master case # if your issue is thought to be related.
Posted Mar 02, 2026 - 22:49 CST
This incident affected: Americas Region (Corrigo Enterprise 9x, CorrigoPro, Enterprise Integrations, Field Service Management, Corrigo Enterprise Reporting Services, Business Intelligence), Asia Pacific Region (Corrigo Enterprise, CorrigoPro, Enterprise Integrations, Corrigo Enterprise Reporting Services), and Europe, the Middle East & Africa Region (Corrigo Enterprise, CorrigoPro, Enterprise Integrations, Corrigo Enterprise Reporting Services).