JLLT OneServiceCenter has been alerted to potential service issues with Corrigo Enterprise - Unable to Create Work Orders in Customer Portal

Incident Report for Corrigo

Update

JLLT OneServiceCenter Teams have been informed that there may be some lingering latency and slowness issues being seen in the Corrigo Enterprise Back Office. The appropriate teams are aware. We will continue to work towards a permanent fix for this issue as well as the Google Maps widget issue, and will update here when more information is available. Please continue to refer to the related Master Case (00948650) if you believe your issues are related.
Posted Nov 21, 2025 - 13:36 CST

Update

JLLT OneServiceCenter Teams are continuing to work on this issue. The map on the Customer Portal application has been temporarily removed. The map on the Work Order pages in Back Office is visible and the latency issues should be resolved. We will continue to work towards a permanent fix for this issue and will update here when more information is available. Please continue to refer to the related Master Case (00948650) if you have issues relating.
Posted Nov 20, 2025 - 17:54 CST

Update

JLL OneServiceCenter teams have identified slowness and latency issues in Corrigo Enterprise. These performance issues may be related to the Google Maps widget problem that our technical team is actively working to resolve. We will continue to update this status page as more information becomes available.
Posted Nov 20, 2025 - 10:18 CST

Update

The Work Order functionality in the Customer Portal desktop application should now be functioning as expected. Due to troubleshooting efforts, the Google Map widget on the Work Order pages in both the Customer Portal and Back Office may be unavailable, or show an error message saying "Something went wrong". We are working to recover this widget. We understand the impact of Google Maps being inaccessible, and will continue to recover full performance. Thank you for your patience.
Posted Nov 19, 2025 - 19:32 CST

Update

Our Product and Engineering teams are continuing to investigate and troubleshoot this issue. We will provide at least one additional update over this evening (CT), and keep this page informed on the status as we have more information. We appreciate your patience. At this time Contacts who are experiencing these issues should try creating the Work Order/Service Request via their Mobile Application.
Posted Nov 19, 2025 - 18:14 CST

Investigating

JLLT OneServiceCenter has been made aware of an issue that may be affecting services with Corrigo Enterprise where Contacts are unable to create Work Orders in Customer Portal.

Users may experience screen lock or error message. This appears to be on desktop only. Mobile versions appear to still be able to create work orders without issue.

Our Product and Engineering teams are actively reviewing this and we will update this status page post when more information or ETA on a fix is provided.

A master case (00948650) has been opened for this issue to track incident volume.
When contacting Support, please reference the master case # if your issue is thought to be related.
Posted Nov 19, 2025 - 15:18 CST
This incident affects: Americas Region (Corrigo Enterprise 9x), Asia Pacific Region (Corrigo Enterprise), and Europe, the Middle East & Africa Region (Corrigo Enterprise).